Calcudoku puzzle forum
http://www.calcudoku.org/forum/

bonus puzzle not validated
http://www.calcudoku.org/forum/viewtopic.php?f=18&t=216
Page 1 of 1

Author:  sneaklyfox  [ Tue May 15, 2012 1:31 am ]
Post subject:  bonus puzzle not validated

Something really odd happened today when I just did the bonus puzzle. I finished it but then nothing happened! Of course, I checked and double-checked and triple-checked my solution because I thought I must have made a mistake but I didn't find any mistake at all. Still, maybe it was my error or I was missing something. I cleared all the cells and did it again but still nothing. I saved the full solution anyway because I don't believe I made any error. Then I went back to the home page and went back into the bonus puzzle page and it then submitted the solution (which was already there) and gave me the points. This has never happened before. Just wanted to mention it. Interestingly, it said it took me 330 milliseconds to complete the puzzle. I guess that's how long it took for the saved solution to appear?

Author:  sjs34  [ Tue May 15, 2012 3:12 am ]
Post subject:  Re: REPORT BUG

That is currently happening to me also on the bonus puzzle but I still can't get my solution accepted.

Author:  beaker  [ Tue May 15, 2012 6:45 am ]
Post subject:  Re: REPORT BUG

Solved puzzle and no reward.....saved for later and am going to try sneaklfox's method.

Also, my Bonus puzzle will not do the automatic checking (ie: red numbers when a mistake is made).

Went back to bonus puzzle after leaving the forum and as soon as I entered the bonus puzzle site the screen turned green and points were awarded.

Author:  clm  [ Tue May 15, 2012 8:28 am ]
Post subject:  Re: REPORT BUG

beaker wrote:
Solved puzzle and no reward.....saved for later and am going to try sneaklfox's method.

Also, my Bonus puzzle will not do the automatic checking (ie: red numbers when a mistake is made).

Went back to bonus puzzle after leaving the forum and as soon as I entered the bonus puzzle site the screen turned green and points were awarded.


Having exactly the same problem with a 7x7 twin bonus puzzle, the first thing I noticed was the failure in the continuous error checking function (this is disabled for timed puzzles). I thought Patrick was making some modifications or improvements. I also made a .pdf with the correct solution (in white, not green) with the idea of sending this info to Patrick but when I reloaded the page (after a while) I had obtained the points and the green screen had appeared. I am sure Patrick is aware of this incidental situation.

Author:  jomapil  [ Tue May 15, 2012 8:49 am ]
Post subject:  Re: REPORT BUG

The same problem with me today ( 15-05-12 ) with the bonus puzzle.

Author:  pnm  [ Tue May 15, 2012 11:05 am ]
Post subject:  Re: bonus puzzle not validated

sneaklyfox wrote:
Something really odd happened today when I just did the bonus puzzle. I finished it but then nothing happened!

Yes, I cleaned up the code behind the main page (note the "W3C XHTML 1.0" icon at the bottom right), and in the
process introduced a bug specific to twin puzzles (which most of the bonus puzzles are). This should be fixed now,
thanks for the report.
sneaklyfox wrote:
Interestingly, it said it took me 330 milliseconds to complete the puzzle. I guess that's how long it took for the saved solution to appear?

Yes, that timer simply measures the time from when the page is loaded until the puzzle is solved.

Patrick

Page 1 of 1 All times are UTC + 1 hour [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/