View unanswered posts | View active topics It is currently Tue Dec 12, 2017 6:07 pm



← Back to the Calcudoku puzzle page




Reply to topic  [ 7 posts ] 
 Firefox-only bugs 
Author Message

Posted on: Wed Jan 16, 2013 2:54 am




Posts: 193
Joined: Tue May 24, 2011 4:55 pm
Post Firefox-only bugs
Today I have observed a number of apparently related bugs when logged in through Firefox. Those bugs are not present when I log in through Internet Explorer. I have also been logged in through Firefox the previous several days without a problem, meaning that the bugs are probably caused by a recent change. I don't know if it has anything to do with Firefox's very recent auto-update from version 17 to version 18, or with my use of Adblock Plus (or any other extension).

Other Firefox users: If you experience any of the problems mentioned below, please report it here so Patrick will know. Otherwise it may just be caused by my specific setup.

Initial observations in Firefox
  • Today the links to puzzles I had solved didn't get a green background as usual, even though I was logged in. When I went back to previous days, the links to solved puzzles still had their green background.
  • At the top of the page where it says "You have x Points (y today)", y equalled 9, which was probably the 9 points I had received when I submitted a book puzzle. Points from solving today's online puzzles were not added to y.
  • When I started doing a new puzzle, the upper left cell was no longer marked in orange. If I pushed the up or left arrow on my keyboard, the upper left cell was marked, and I could proceed as usual. (In fact, if I pushed a number key before any arrow key, the number was filled into the upper left cell, but the cell was still unmarked. It did get marked if I moved to another cell and then returned to it.)
  • I thought I would use the workaround of clicking the "Save for later" button when all cells except one were filled in, and then come back later in the day. When I clicked the button, the text to the right of it duly changed to "Your solution last saved at: [time]", but when I returned to the puzzle, it was empty – no trace of the saved numbers.
  • When I finished a puzzle, the puzzle itself turned green as usual, but there didn't appear any congratulations message saying that a number of points had been added to my total.

Additional observations from Internet Explorer
  • Things worked as usual. The upper left cell in each puzzle was marked in orange, and the numbers I had saved in some puzzles in Firefox, only to have them "disappear", were all there in IE [smile]

Back in Firefox
  • Points earned from completing puzzles in IE had been added to today's total.
  • Links to puzzles solved in IE now had a green background.
  • Saved numbers that had been visible in IE were still missing.
  • All the Firefox-specific bugs mentioned above persisted. [sad]


Profile
Online
User avatar

Posted on: Wed Jan 16, 2013 12:32 pm




Posts: 2215
Joined: Thu May 12, 2011 11:58 pm
Post Re: Firefox-only bugs
Thanks for the detailed bug report.

Crazily enough, I had no problem in Firefox 18 (which I use for testing now),
but was able to reproduce errors in IE 9 (?!).

I've put in a few fixes, let me know if things work ok now.

I should switch to proper use case testing (create a couple of automated tests in Selenium,
run them on all major browsers..)

Patrick


Profile

Posted on: Wed Jan 16, 2013 5:32 pm




Posts: 93
Joined: Sat May 14, 2011 1:08 am
Post Re: Firefox-only bugs
pnm wrote:
Thanks for the detailed bug report.

Crazily enough, I had no problem in Firefox 18 (which I use for testing now),
but was able to reproduce errors in IE 9 (?!).

I've put in a few fixes, let me know if things work ok now.

I should switch to proper use case testing (create a couple of automated tests in Selenium,
run them on all major browsers..)

Patrick


I had the problem both with FF 18 and IE 9. It's working now, but every time I go back to the main puzzle page or for that matter any page I hit "save for later" on I get the congratulations box with "You've solved this puzzle before though."


Profile

Posted on: Wed Jan 16, 2013 7:55 pm




Posts: 193
Joined: Tue May 24, 2011 4:55 pm
Post Re: Firefox-only bugs
pnm wrote:
Crazily enough, I had no problem in Firefox 18 (which I use for testing now), but was able to reproduce errors in IE 9 (?!).
Strange indeed [omg]

pnm wrote:
I've put in a few fixes, let me know if things work ok now.
No problems in Firefox 18 now – thanks for fixing [thumbup]


Profile
Online
User avatar

Posted on: Wed Jan 16, 2013 8:53 pm




Posts: 2215
Joined: Thu May 12, 2011 11:58 pm
Post Re: Firefox-only bugs
mparisi wrote:
I had the problem both with FF 18 and IE 9. It's working now, but every time I go back to the main puzzle page or for that matter any page I hit "save for later" on I get the congratulations box with "You've solved this puzzle before though."

Can you explain this a bit more?

It will be true that if you complete a puzzle, and then do "Save for later", the next time
you load that puzzle page the completed solution will be loaded and resubmitted.

In other news, for the new "custom cell size" feature I was using a feature of Javascript
that apparently is not supported in Internet Exploder 7... :-(
I rewrote the relevant bit such that it now also runs in IE7 [bored]


Profile

Posted on: Thu Jan 17, 2013 2:42 am




Posts: 93
Joined: Sat May 14, 2011 1:08 am
Post Re: Firefox-only bugs
pnm wrote:
mparisi wrote:
I had the problem both with FF 18 and IE 9. It's working now, but every time I go back to the main puzzle page or for that matter any page I hit "save for later" on I get the congratulations box with "You've solved this puzzle before though."

Can you explain this a bit more?

It will be true that if you complete a puzzle, and then do "Save for later", the next time
you load that puzzle page the completed solution will be loaded and resubmitted.


That's what I did, thinking that was the best way to avoid retyping my solution after you fixed the problem.


Profile
Online
User avatar

Posted on: Thu Jan 17, 2013 11:27 am




Posts: 2215
Joined: Thu May 12, 2011 11:58 pm
Post Re: Firefox-only bugs
mparisi wrote:
That's what I did, thinking that was the best way to avoid retyping my solution after you fixed the problem.

Ah, ok, that makes sense.

No real issue then :-)


Profile
Display posts from previous:  Sort by  
Reply to topic   [ 7 posts ] 

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
All forum contents © Patrick Min, and by the post authors.

Forum software phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware.