View unanswered posts | View active topics It is currently Tue Oct 17, 2017 10:30 pm



← Back to the Calcudoku puzzle page




Reply to topic  [ 10 posts ] 
 errors using Safari on Macbook 
Author Message

Posted on: Sun Jan 20, 2013 1:10 pm




Posts: 8
Joined: Fri May 13, 2011 1:58 am
Post errors using Safari on Macbook
I'm getting very similar problems using Safari on my MacBook. The top-left square doesn't turn orange unless I press a cursor key or click in the square and when I complete the puzzle, I get no congratulatory response, and worse, no points! The problem doesn't happen with all the puzzles, usually just the 4x4 and 5x5 I think. Will try to get more info to send in the next few days unless it gets fixed before then. No problem when I use Internet Explorer on a PC though - except I don't normally have access to that (my son's using it for Runescape most of the time....sigh.) [crying]


Profile
User avatar

Posted on: Sun Jan 20, 2013 1:32 pm




Posts: 2192
Joined: Thu May 12, 2011 11:58 pm
Post Re: Firefox-only bugs
ric3142 wrote:
I'm getting very similar problems using Safari on my MacBook

Sorry about that, will check.
Which OS are you using, and which version of Safari?

Just tested Safari 4.1.3 on OS X 10.4.11,
Safari 5.1.7 on OS X 10.6.8, and Safari 6.0 on OS X 10.8, all worked ok.

Also checked Safari 4, 5.0, 5.1, and 6.0 via "browsershots.org", all ok (?!)

[confused]

Patrick


Profile

Posted on: Sun Jan 20, 2013 8:00 pm




Posts: 116
Joined: Sat May 14, 2011 3:18 am
Post Re: errors using Safari on Macbook
I've not seen any problems with not getting a congratulatory message or points, and the top left square always turns orange when I load the puzzle for the first time, BUT I have noticed (for a LONG time now) that when the puzzle is reloaded from the saved state, the top left square is never orange. As soon as I move out of that square, I get the orange indicator for the current cell location.

I actually kind of like that feature, though, for the times when I want to take a screen shot without having the orange square in it.


Profile
User avatar

Posted on: Sun Jan 20, 2013 8:50 pm




Posts: 2192
Joined: Thu May 12, 2011 11:58 pm
Post Re: errors using Safari on Macbook
pharosian wrote:
BUT I have noticed (for a LONG time now) that when the puzzle is reloaded from the saved state, the top left square is never orange. As soon as I move out of that square, I get the orange indicator for the current cell location.

Can you let me know the exact sequence to reproduce this error?

I tested this using the aforementioned Safari + OS X combinations, but couldn't reproduce it...

thanks,

Patrick


Profile

Posted on: Sun Jan 20, 2013 9:57 pm




Posts: 8
Joined: Fri May 13, 2011 1:58 am
Post Re: errors using Safari on Macbook
Hi Pat, I'm using Safari 5.1.7 on OSX 10.6.8. This problem has been occurring for about a week I think, or maybe a few days longer. [blink]

It just seems that the page is not fully loading. In fact I've just missed out on both my timed 5x5s for today as the puzzle itself didn't load. [cursing]

Richard


Profile
User avatar

Posted on: Sun Jan 20, 2013 10:12 pm




Posts: 2192
Joined: Thu May 12, 2011 11:58 pm
Post Re: errors using Safari on Macbook
ric3142 wrote:
Hi Pat, I'm using Safari 5.1.7 on OSX 10.6.8. This problem has been occurring for about a week I think, or maybe a few days longer. [blink]

I have a Mac mini here with 5.1.7, so I can do some more focused testing.

What is the exact sequence you follow?

For example, 1) login, 2) go to 4x4 easy, etc.

Or is it something that happens for every puzzle?

Can you try and clear your cookies and load the page again?

thanks,

Patrick


Profile

Posted on: Mon Jan 21, 2013 4:08 am




Posts: 116
Joined: Sat May 14, 2011 3:18 am
Post Re: errors using Safari on Macbook
pnm wrote:
pharosian wrote:
BUT I have noticed (for a LONG time now) that when the puzzle is reloaded from the saved state, the top left square is never orange. As soon as I move out of that square, I get the orange indicator for the current cell location.

Can you let me know the exact sequence to reproduce this error?

I tested this using the aforementioned Safari + OS X combinations, but couldn't reproduce it...

thanks,

Patrick


OK, maybe "never" was the wrong word... [blush] After doing some testing, it appears that if I save a puzzle and have turned on the "bold" feature for the upper left cell, then when I open the puzzle from a different page (didn't think to try "refresh"), the top left square is green, not orange.


Profile
User avatar

Posted on: Mon Jan 21, 2013 11:40 am




Posts: 2192
Joined: Thu May 12, 2011 11:58 pm
Post Re: errors using Safari on Macbook
pharosian wrote:
OK, maybe "never" was the wrong word... [blush] After doing some testing, it appears that if I save a puzzle and have turned on the "bold" feature for the upper left cell, then when I open the puzzle from a different page (didn't think to try "refresh"), the top left square is green, not orange.

Ah, right: a saved puzzle is loaded after the orange "cursor" is shown,
and only if the top left cell was bolded, its colour is changed.

That's easily fixable, but not a big problem I think.

(more important to get to the bottom of the error that ric3142 is experiencing)


Profile

Posted on: Thu Jan 24, 2013 5:14 am




Posts: 8
Joined: Fri May 13, 2011 1:58 am
Post Re: errors using Safari on Macbook
Hi Pat, I have tried emptying the cache, but to no avail. I generally just stay logged in to the site unless some glich logs me out for no apparent reason - why does that happen anyway?

Anyway, it seems that the problem in question only occurs with the 5x5's - the others all behave as they should. The 5x5 timed puzzles don't even show on the screen. I also notice that the ordinary 5x5's don't automatically resize when they load. BTW, the puzzles do turn all green when the last cell is correctly completed, so the checking is happening but as I said before, the congratulatory screen does not display and I don't get the points added to my total. I can save the puzzle at this point and if I take the trouble to boot my son off the Windows PC, log on there and get to the 5x5, I do get the congratulations and the points. A bit of a pain though lol. [glare]

Richard


Profile
User avatar

Posted on: Sat Jan 26, 2013 6:10 pm




Posts: 2192
Joined: Thu May 12, 2011 11:58 pm
Post Re: errors using Safari on Macbook
Hi ric3142,

I replied to you via e-mail, did you receive it?

Patrick


Profile
Display posts from previous:  Sort by  
Reply to topic   [ 10 posts ] 

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
All forum contents © Patrick Min, and by the post authors.

Forum software phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware.